If you’re running a modern version of OSX then you’re likely running Java 11, which is fine until you need to run npm/gulp tests with Selenium (which requires Java8). jenv to the rescue! assuming you have homebrew installed brew tap caskroom/versions brew cask install java8 brew install jenv then either update your ~/.bash_profile or (if you have one) ~/.path file export PATH="$HOME/.jenv/bin:$PATH" eval "$(jenv init -)" & reload your shell.